about widget construction kit

Fredrik Lundh fredrik at pythonware.com
Sat Nov 12 14:11:17 CET 2005


"Shi Mu" wrote:

> > > I tried again and got the follwoing message:
> > > *** cannot find Tcl/Tk headers and library files
> > >     change the TCL_ROOT variable in the setup.py file
> > > but i have already installed TCL under python23
> >
> > hmm.  I still think it would be easier if you used a prebuilt version, like
> > everyone else.
> >
> > (if you insist on using an old source release instead of the latest binaries,
> > follow the instructions, and make sure the TCL_ROOT variable points to
> > the location of the Tcl/Tk development libraries (the directory that con-
> > tains Tcl's "include" and "lib" directories, that is))
>
> what is Tcl/Tk development libraries?

the stuff you get if you install tcl-devel/tk-devel on unix, or a complete
Tcl/Tk distribution on Windows (e.g. ActiveTcl).

> I have a tcl folder under c:\python23. Is that what you mean?

if you set TCL_ROOT to that directory and setup still says that it cannot
find the development files, the answer is most likely "no".

can you explain why you cannot use a prebuilt version?

</F>






More information about the Python-list mailing list