installing PygreSQL and psychopg2 modules (a newbie question)

Zlatko Matić zlatko.matic1 at sb.t-com.hr
Wed Nov 2 23:10:37 CET 2005


Hello.
I was trying to install PygreSQL and psychopg2 in order to use python as front-end for PostgreSQL, on WIndows XP. 
When I tried to install by calling setup.py from command prompt ("setup.py install"), in both cases I had the same error:

"error: Python was built with version 7.1 of Visual Studio, and extensions need to be built with the same version of the compiler, but it isn't installed."

It looks like this:
"C:\Downloads\Python\psychopg\psycopg2-2.0b5\psycopg2-2.0b5>setup.py install
running install
running build
running build_py
running build_ext
building 'psycopg2._psycopg' extension
error: Python was built with version 7.1 of Visual Studio, and extensions 
need t
o be built with the same version of the compiler, but it isn't installed.

C:\Downloads\Python\psychopg\psycopg2-2.0b5\psycopg2-2.0b5>pause
Press any key to continue . . ."

What does it mean ? What am I supposed to do?

Thanks,

Zlatko
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20051102/aeb83027/attachment.html>


More information about the Python-list mailing list