Idle

petercable at gmail.com petercable at gmail.com
Wed Oct 5 02:34:17 CEST 2005


If you are compiling python and you want to build idle/tkinter, you
need to have the development packages for tcl and tk. The python build
scripts will only build tkinter should they find the libraries
(libtk8.4.so and libtcl8.4.so) and the header files (tk.h and tcl.h).
If you don't have the development packages installed, you most likely
do not have the header files.

If you install the development packages and recompile, test by
importing _tkinter. If that is successful, idle should run just fine.




More information about the Python-list mailing list