ZPT and "incompatible version None" error :(

Jaroslaw Zabiello hipertracker at gmail.com
Mon Sep 12 16:51:48 CEST 2005


I got strange errors in Zope 2.7.

    METALError
    macro 'context/base' has incompatible version None, at line 1, column 1

One ZPT file (named 'base') defines some simply slots:

<html
    xmlns="http://www.w3.org/1999/xhtml"
    xml:lang="en-US"
    lang="en-US"
    i18n:domain="plone"
    metal:use-macro="here/main_template/macros/master">
  <body>
    <div metal:fill-slot="main">
      <div metal:define-macro="content">
       <div metal:define-slot="gora">[up]</div>
       <div metal:define-slot="srodek">[middle]</div>
       <div metal:define-slot="dol">[bottom]</div>
      </div>
    </div>
  </body>
</html>

Another ZPT file try to fill one slot:

<div metal:use-macro="context/base">
  <div metal:fill-slot="gora">Search|Read|Compare|History</div>
</div>

When I try to open it, I get the error mentioned above. Any idea?

--
JZ



More information about the Python-list mailing list