How to upgrade to 2.4.1 on Mac OS X tiger

Mike Meyer mwm at mired.org
Tue Sep 13 02:40:41 CEST 2005


Robert Kern <rkern at ucsd.edu> writes:
>> Come to think of it, what's installed by Apple may count as a
>> different distribution as well. It certainly includes more than just
>> the official distribution.
> It's also old and probably won't be the same version in 10.5. If you
> want any control over how you distribute your apps, use the official
> 2.4.1 binary and embed the interpreter inside your .app bundle with py2app.

IIRC, 10.4.2 ships with a more recent release than 2.4.1 - it comes
with 2.3.5. What I may not be recalling correctly is whether 2.3.5
postdates 2.4.1 or not.

For my uses - developing Unix server-side applications - which version
of Tk it links with is irrelevant. My Mac is a Unix laptop with
hardware support from the vendor. That it runs commercial apps under
Aqua is a nice bonus. That I can't get my favorite X wm on working on
it is unfortunate.

Come to think of it, that problem is OT for c.l.python - because my X
wm is written in Python, using python-xlib. So to post...

   <mike
-- 
Mike Meyer <mwm at mired.org>			http://www.mired.org/home/mwm/
Independent WWW/Perforce/FreeBSD/Unix consultant, email for more information.



More information about the Python-list mailing list