[OT] How can I change Debian's default Python version?

Robert Kern robert.kern at gmail.com
Thu Jan 5 17:23:41 CET 2006


Franz GEIGER wrote:
> Diez B. Roggisch wrote:
> 
>>sudo apt-get install python-wxgtk2.6
>>
>>Which depends on python2.4
> 
> No, sorry, at least not on all my Sarge boxes. I'm told "needs python2.3"
> when I look at its properties from within Synaptic (Dependency Tab): Needs
> python-wxversion, needs python2.3, needs libc6 (>= 2.3.5-1) etc. etc.

As of this time, the Debian wxPython packages are only provided for Python 2.3.
I couldn't tell you why. Try looking at the bug list for python-wxgtk2.6. I'm
sure there's a bug filed against it asking for a Python 2.4 version. Perhaps the
maintainer has explained why there is no such version yet.

-- 
Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter




More information about the Python-list mailing list