Wingide is a beautiful application

SPE - Stani's Python Editor spe.stani.be at gmail.com
Sun Jan 15 07:20:48 CET 2006


Sybren Stuvel schreef:

> Sybren Stuvel enlightened us with:
> > SPE is already annoying because of all the new windows it opens...
> > Not a good start.
If you mean terminal windows, that has gone with the latest release
0.8.1.d, see http://pythonide.stani.be/blog

> > I remember using it before, to check out the
> > Blender integration. Unfortunately, that didn't work. I'll give it
> > another go.
>
> I downloaded it, tried to run it, then it stopped with a message that
> it needs a newer wxPython version than the one that comes with Ubuntu
> Linux. Since this release of Ubuntu is two months old and rather up to
> date with all things Python, IMO the SPE builders are pushing it a
> little too much by requiring even a newer version of wxPython.

This is a misinterpretation, SPE failed because of something else. (As
would have become clear if you would have run SPE in the debugging mode
'python SPE.py --debug'.) The version number displayed is the one on
which SPE is being developed, not the one required (displayed on
webpage). AFAIK SPE runs fine with wxPython 2.5.4.1+ I run SPE myself
on the same release of Ubuntu as you (Breezy ?)  and it now works very
well.

>From the SPE news blog:

SPE was for the first time tested on and improved for Ubuntu (and
hopefully so for Linux in general). I adapted SPE such that it can ran
out of the box of an archive (zip or tar.gz). This has the advantage
that Linux (but also Mac and Windows) don't have to install SPE anymore
but can just run it out of a folder or USB stick, provided the right
version of wxPython (2.6) is installed on the system as it is always
the case with Ubuntu boxes. If you want to install SPE in this way, use
the -no_setup.zip distribution:

   1. uninstall previous version of SPE (VERY IMPORTANT, otherwise SPE
won't run)
   2. download and unpack the archive
SPE-0.8.1.d-wx2.6.1.0-no_setup.zip
   3. run SPE with 'python SPE.py'

If it doesn't work, let me know privately.

Stani




More information about the Python-list mailing list