config errors on Freebsd and python 2.3

David Bear david.bear at asu.edu
Fri Jan 6 02:04:30 CET 2006


I need python 2.3. I have freebsd 4.10-releng. when configuring python I
received the following:

./configure --prefix=/home/webenv > config-results
configure: WARNING: curses.h: present but cannot be compiled
configure: WARNING: curses.h:     check for missing prerequisite headers?
configure: WARNING: curses.h: see the Autoconf documentation
configure: WARNING: curses.h:     section "Present But Cannot Be Compiled"
configure: WARNING: curses.h: proceeding with the preprocessor's result
configure: WARNING: curses.h: in the future, the compiler will take
precedence
configure: WARNING:     ## --------------------------------- ##
configure: WARNING:     ## Report this to the python lists.  ##
configure: WARNING:     ## --------------------------------- ##
configure: WARNING: ncurses.h: present but cannot be compiled
configure: WARNING: ncurses.h:     check for missing prerequisite headers?
configure: WARNING: ncurses.h: see the Autoconf documentation
configure: WARNING: ncurses.h:     section "Present But Cannot Be Compiled"
configure: WARNING: ncurses.h: proceeding with the preprocessor's result
configure: WARNING: ncurses.h: in the future, the compiler will take
precedence
configure: WARNING:     ## --------------------------------- ##
configure: WARNING:     ## Report this to the python lists.  ##
configure: WARNING:     ## --------------------------------- ##

I don't plan on using curses -- so I'd like to ignore this. But, I'm just
wondering if there is an 'easy' fix...


-- 
David Bear
-- let me buy your intellectual property, I want to own your thoughts --



More information about the Python-list mailing list