Debugging python 2.2 code with Pydev

Fabio Zadrozny fabioz at esss.com.br
Wed Jan 18 18:21:34 CET 2006


Actually, the issue is already solved...

Will be available in the next release (if you have this problem and want 
it now, just contact me... it is just because of a Boolean Type -- just 
checking a NameError does the trick to use it in python 2.2).

As for the interpreter... nope, pydev does not use the same interpreter 
it uses itself  -- it is MUCH more customizable than that... just 
imagine... your IDE crashing because of an error you did in your code... 
seem pretty crazy to me ;-)

Cheers,

Fabio

Fuzzyman wrote:

>*Looks* like the plugin code isn't compatible with Python 2.2. (Some
>change in the way imports are resolved ?).
>
>PyDev will almost certainly use the same interpreter to run the code as
>the one it is using itself...
>
>There is possibly a PyDev mailing list to check on though.
>
>You could try installing Python 2.3 to see if the problem goes away.
>
>Movable Python is a good way to develop for multiple versions of Python
>on a windows box. Unless you can configure PyDevf to use a different
>execuatable to run scripts with, you won't be abel to do this from
>within PyDev though. You can switch to SPE of course, which has many
>other advantages (otehr than being bundled with Movable Python) ;-)
>
>http://www.voidspace.org.uk/python/movpy/
>http://pythonide.stani.be
>
>All the best,
>
>Fuzzyman
>http://www.voidspace.org.uk/python/index.shtml
>
>  
>





More information about the Python-list mailing list