language-x-isms

Alan Kennedy alanmk at hotmail.com
Thu Jun 8 12:40:47 CEST 2006


[Steve Holden]
> You are assuming a relatively recent release of CPython. If you look at
> the stuff that the effbot distributes you will see that most of it
> supports CPython all the way back to 1.5.2.

Oh for cripes sake.

The code I posted

1. works on all versions of cpython
2. works on all versions of jython
3. works on all versions of ironpython
4. never replaces the builtin enumerate

> I don't think many of us
> have the right to be telling Fredrik what's pythonic and what's not ...

Who ever said anything like that? I never said anything about
pythonicity. Read the thread again: All I said was "Here's what I use
on jython 2.1".

Fred picked a non-existent hole in my code by saying "using a
user-defined enumerate is slower than using the builtin", implying that
the code I posted replaced the builtin, which it never does.

While the comment "using a user-defined enumerate is slower than using
the builtin" may be true, it has no bearing on the code I posted, which
is all I'm trying to say ...

--
alan kennedy
------------------------------------------------------
email alan:              http://xhaus.com/contact/alan




More information about the Python-list mailing list