Installation Problem

Marshall Dudley mdudley at king-cart.com
Sun Jun 4 19:31:12 CEST 2006


Fredrik Lundh wrote:

> Marshall Dudley wrote:
> > I am trying to install python, but am having problems.  I did what the
> > README file said, and it created an executible code in the current
> > directory as it said it would when I typed "make".
>
> "make" doesn't install the interpreter by itself; you're supposed to use
> "make install" (or "make altinstall") to do that.
>
> just copying the interpreter binary around won't give you a complete
> install.
>
>  > It seemed to say to copy the executable over to the /usr/local
>  > directory, which I did.
>
> the README says:
>
>    To start building right away (on UNIX): type "./configure" in the
>    current directory and when it finishes, type "make".  This creates an
>    executable "./python"; to install in /usr/local, first do "su root"
>    and then "make install".

Yes, that is what I did. Since I ended up with no executable in /usr/local,
or /usr/local/bin and it said " This creates an
   executable "./python" (which it did); to install in /usr/local" I copied
the one it created over to /usr/local, then later /usr/local/bin

>
>
> the detailed installation section says:
>
>    To install the Python binary, library modules, shared library modules
>    (see below), include files, configuration files, and the manual page,
>    just type
>
>          make install
>
>     /.../
>
> </F>

Yes, I typed "make install".  But nothing gets put into /usr/local or
/usr/local/bin without me copying it over.  And if I run python it in the
directory I unpacked it in, it works, but if I run the copy in /usr/local or
/usr/local/bin it does not.

I also tried the instuctions on their web site:

"python setup.py install"

But get the same result, but it copies and puts the following 3 files in the
/usr/local/bin dir.

-rwxr-xr-x  1 root  wheel       96 May 31 07:50 idle
-rwxr-xr-x  1 root  wheel       81 May 31 07:50 pydoc
-rwxr-xr-x  1 root  wheel    18017 May 31 07:50 smtpd.py

Marshall




More information about the Python-list mailing list