what is pygtk.require("2.0") for?

Matt Good matt.good at gmail.com
Wed Jun 28 04:57:01 CEST 2006


yaru22 wrote:
> when I read a book, it just said we need to do
>
> import pygtk
> pygtk.require("2.0")
> import gtk
>
> in order to import gtk modules
>
> What is that pygtk.require("2.0") command for?

It enables you to install multiple versions of pygtk in parallel and
makes sure when you do "import gtk" you get the version you're
expecting.  See the FAQ for more info:
http://www.async.com.br/faq/pygtk/index.py?req=show&file=faq02.004.htp




More information about the Python-list mailing list