suse linux 10 and wx.listctrl display issues

ianaré ianare at gmail.com
Wed Mar 8 07:29:51 CET 2006


hey,

Having some problems getting wxpython apps to look right on SuSE 10.0
and KDE 3.4.
There are no RPMs that i could find so I built my own from source.
First time using 'default' settings - GTK 2.x and unicode:

rpmbuild -tb --define 'pyver 2.4' --define 'port gtk2' \
--define 'unicode 1' wxPython-src-2.6.2.1.tar.

I can run my apps but they look, well, funky. Mainly the background
color for my wx.listctrl's are unchangeable, and these default to the
same color as the window background, making them hard to see. Also some
widgets are positioned improperly... although i could maybe fix this by
tweaking sizers around.
I had an earlier (prior to HDD crash :( ) debian 3.1 install and
everything was fine, using similar configs... though i'm fairly sure
the KDE version was lower. I tried several different window styles and
themes to no avail.  Finally I tried making another set of RPMs, this
time like so:

rpmbuild -tb --define 'pyver 2.4' --define 'port gtk' \
--define 'unicode 0' wxPython-src-2.6.2.1.tar.

(using GTK 1.2, ansi build).. and now my I can see my lists properly
but everything else looks absolutly disgusting !! looks like circa 1990
LOL, besides it's very hard to see anything due to tiny text and oddly
shaped/shaded widgets.

Is there a fix, or at least a step in the right direction for this? I'm
really liking SuSE 10 otherwise -especially YaST - and don't really
want to go back to debian over a wx.listctrl.




More information about the Python-list mailing list