Trouble with numpy-0.9.4 and numpy-0.9.5

drife daranrife at yahoo.com
Wed Mar 1 18:41:01 CET 2006


Hello,

I use the Python Numeric package extensively, and had been an
avid user of the "old" scipy. In my view, both pieces of software
are truly first rate, and have greatly improved my productivity in
the area of scientific analysis. Thus, I was excited to make the
transition to the new scipy core (numpy).

Unfortunately, I am experiencing a problem that I cannot sort
out. I am running Python 2.4.2 on a Debian box (V3.1), using
gcc version 3.3.5, and ATLAS, BLAS, and LAPACK libraries
built from scratch. When building numpy everything seems to
go AOK. But trouble soon follows.

As a sanity check, I run the diagnostic tests that come as
part of the numpy package:

from numpy import *
from scipy import *

test(level=N)  #  N can vary from 1 to 10. :


No matter which test I run, Python crashes hard with only
the following output: "Floating exception".

I thought perhaps numpy would still work Ok, even though
it seemed to have failed this "sanity" test.

Thus, I tried using the numpy.linalg.eig functionality, and
upon calling numpy.linalg.eig I get the same behavior:
Python crashes hard with the same output "Floating
exception".

Can someone help me sort out what might be wrong?
Perhaps I have overlooked a crucial step in the build/
install of numpy.


Thanks very much,


Daran




More information about the Python-list mailing list