SPE / winpdb problem

Steve Holden steve at holdenweb.com
Mon May 1 14:10:17 CEST 2006


MakaMaka wrote:
> Hi All,
> I'm having a problem with Stani's Python Editor (SPE) that I'm hoping
> somebody has run into before.  If I create a simple hello world
> program:
> 
> print "hello"
> 
> and try and run it in winpdb via the SPE command ALT-F9, the program
> does not launch and the following results (It's at the bottom):
> 
> 
> Spe Warning: Spe was developped on wxPython v2.6.1.0., but v2.6.3.2.
> was found.
> If you experience any problems please install wxPython v2.6.1.0.
> 
> 
> SPE v0.8.2.a (c)2003-2005 www.stani.be
> 
> If spe fails to start:
>  - type "python SPE.py --debug > debug.txt 2>&1" at the command prompt
>    (or if you use tcsh: "python SPE.py --debug >& debug.txt")
>  - send debug.txt with some info to spe.stani.be[at]gmail.com
> 
> 
> Spe Warning: Spe was developped on wxPython v2.6.1.0., but v2.6.3.2.
> was found.
> If you experience any problems please install wxPython v2.6.1.0.
> 
> Blender support disabled (run SPE inside Blender to enable).
> 
> Encrypted debugging disabled.
>   If you prefer encrypted debugging, install the "Python Cryptography
> Toolkit"
>   from http://www.amk.ca/python/code/crypto
> 
> Launching application...
> Traceback (most recent call last):
>   File "C:\Python24\lib\site-packages\_spe\plugins\winpdb\winpdb.py",
> line 3313,
>  in ?
>     ret = main()
>   File "C:\Python24\lib\site-packages\_spe\plugins\winpdb\winpdb.py",
> line 3303,
>  in main
>     return rpdb2.main(StartClient)
>   File "C:\Python24\Lib\site-packages\_spe\plugins\winpdb\rpdb2.py",
> line 7221,
> in main
>     StartClient_func(_args, fAttach, fchdir, pwd, fAllowUnencrypted,
> fRemote, ho
> st)
>   File "C:\Python24\lib\site-packages\_spe\plugins\winpdb\winpdb.py",
> line 3293,
>  in StartClient
>     app = CWinpdbApp(sm, fchdir, command_line, fAttach,
> fAllowUnencrypted)
>   File "C:\Python24\lib\site-packages\_spe\plugins\winpdb\winpdb.py",
> line 1528,
>  in __init__
>     wx.App.__init__(self, redirect = False)
>   File "C:\Python24\Lib\site-packages\wx-2.6-msw-ansi\wx\_core.py",
> line 7700, i
> n __init__
>     self._BootstrapApp()
>   File "C:\Python24\Lib\site-packages\wx-2.6-msw-ansi\wx\_core.py",
> line 7352, i
> n _BootstrapApp
>     return _core_.PyApp__BootstrapApp(*args, **kwargs)
>   File "C:\Python24\lib\site-packages\_spe\plugins\winpdb\winpdb.py",
> line 1533,
>  in OnInit
>     self.m_settings.load_settings()
>   File "C:\Python24\lib\site-packages\_spe\plugins\winpdb\winpdb.py",
> line 638,
> in load_settings
>     d = cPickle.load(f)
> EOFError
> 
> 
> 
> Any ideas what is going on?
> 
> Thanks!
> 
I'd try installing wxPython v2.6.1.0 and see if that gets rid of your 
error. Multiple versions can coexist.

regards
  Steve
-- 
Steve Holden       +44 150 684 7255  +1 800 494 3119
Holden Web LLC/Ltd          http://www.holdenweb.com
Love me, love my blog  http://holdenweb.blogspot.com
Recent Ramblings     http://del.icio.us/steve.holden




More information about the Python-list mailing list