Building Python (2.4.x) with Visual C++ 2005 Express Edition?

Vincent Wehren vwehren at home.nl
Sat May 6 15:48:37 CEST 2006


Heikki Toivonen" <heikki at osafoundation.org> wrote in message 
news:tr2dnYBW2uZDRsbZRVn-ig at comcast.com...
|I did some searches but did not find any definitive answers as to
| whether or not it should be possible to build Python 2.4+ with Microsoft
| Visual C++ 2005 Express Edition.
|
| I tried it myself (have VC++ project files that work with Visual Studio
| 2003 .NET commercial version, just opened and closed them in vcexpress
| to convert the projects) and the compilation finished without errors
| (although with a bunch of deprecation warnings). But when I try to run,
| python crashes on startup.
|
| Has anyone gotten this to work?
|
| -- 
|  Heikki Toivonen

Looking at your post, I tried building 2.4.3 using Visual Studio 2005 
Professional - but ran into trouble with the way signals are treated by the 
new CRT (which may be the error you are talking about).
I saw there was a patch on 
http://sourceforge.net/tracker/index.php?func=detail&aid=1350409&group_id=5470&atid=305470 
which apparently has been applied to 2.5a2 - which started fine after 
building debug.

Maybe this helps?

Regards,

Vincent Wehren







More information about the Python-list mailing list