urllib2: HTTP Version not supported

Nirnimesh nirnimesh at gmail.com
Thu Nov 2 13:52:05 CET 2006


I'm using urllib2 module to fetch a URL from a server which understands
HTTP/1.1 only (no HTTP/1.0).

urllib2.urlopen() results in "urllib2.HTTPError: HTTP Error 505: HTTP
Version not supported".

How do I force urllib2 to use HTTP v1.1?

Regards,
Nirnimesh




More information about the Python-list mailing list