failure building python 2.5 on mac os x 10.3.9

Markus Rosenstihl mrosenstihl at macnews.de
Thu Nov 30 18:39:16 CET 2006


On 2006-11-19 15:50:14 +0100, Thomas Ploch <Thomas.Ploch at gmx.net> said:

> Hello,
> 
> I followed the instructions in the Mac/README file.
> 
> I ran ./configure --enable-framework
> 
> But when I try to build from source with gcc 4.0.2, following happens:
> 
> 
> [snip]
> libtool: can't locate file for: -lSystemStubs
> libtool: file: -lSystemStubs is not an object file (not allowed in a
> library)
> make: *** [Python.framework/Versions/2.5/Python] Error 1
> 
> What does that mean?
> 
> Thanks,
> Thomas

I had the same problem (why do you have gcc-4.0.2?).

-lSystemStubs is in Tiger


First of all, try to install the 10.4 SDK as it will keep you away of a 
lot of linking problems and such stuff. (yes, it will install on 10.3.9 
and since then i had no compile problems, i found this as an answer in 
a post in the apple discussions)

Then try to compile it again after you have deleted the python source 
tree (or "make clean").
If that is still not working you have to edit the Makefile from Python 
and remove the -lSystemStubs
(i think both ways work, but i am not sure)

Make sure you have either a patched readline 5.1 or better a readline 
5.2. Otherwise you will get segmentation faults when you are using 
ipython.


If it is still not working,
Good luck!





More information about the Python-list mailing list