Tkinter & Python 2.5 Problems on MAC OS 10.3.9

Thomas Ploch Thomas.Ploch at gmx.net
Thu Nov 16 12:10:50 CET 2006


Hello folks,

Since this is my first post on the list, a brief introduction of myself.

My name is Thomas, I am 26 years old, I am a student of Computational  
Linguistics and I am a python user. :-)

Now my problem:

I have Tcl/Tk 8.4.4 installed:

iPimpG4:~ profipimp$ tclsh
% info patchlevel
8.4.4
%

But when I try to import Tkinter

>>> import Tkinter
Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
   File  
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/lib-tk/Tkinter.py",  
line 38, in <module>
     import _tkinter # If this fails your Python may not be configured for  
Tk
ImportError: dlcompat: dyld:  
/Library/Frameworks/Python.framework/Versions/2.5/Resources/Python.app/Contents/MacOS/Python  
can't open library: /Library/Frameworks/Tk.framework/Versions/8.4/Tk  (No  
such file or directory, errno = 2)

>>>

...this happens.

Why?

Tkinter worked perfectly with 2.3 and 2.4...

Cheers,
Thomas



More information about the Python-list mailing list