Problem with ez_setup on a "non-networked" machine

Diez B. Roggisch deets at nospam.web.de
Tue Oct 3 19:33:39 CEST 2006


alex23 schrieb:
> Hey everyone,
> 
> I'm trying to install setuptools on a work PC behind an NTLM firewall.
> I've tried to use APS as recommended but am still unable to have
> anything other than IE talk through firewall. But as I can downloaded
> eggs manually, I'm not overly concerned at this point.
> 
> So I've tried following the instructions for un-networked installs:
> I've downloaded ez_setup.py and setuptools-0.6c3-py2.4.egg, putting the
> egg file in the same folder as ez_setup.
> 
> No matter what comline args I try, though, it always seems to try to
> grab the egg from the Cheeseshop. I naively started off with:
> 
> D:\downloads>ez_setup setuptools
> Downloading
> http://cheeseshop.python.org/packages/2.4/s/setuptools/setuptools-0.6c3-py2.4.egg
> Traceback (most recent call last):
>   File "D:\downloads\ez_setup.py", line 217, in ?
>     main(sys.argv[1:])
>   File "D:\downloads\ez_setup.py", line 149, in main
>     egg = download_setuptools(version, delay=0)
>   File "D:\downloads\ez_setup.py", line 131, in download_setuptools
>     src = urllib2.urlopen(url)
>   File "C:\Python24\lib\urllib2.py", line 130, in urlopen
>     return _opener.open(url, data)
>   File "C:\Python24\lib\urllib2.py", line 358, in open
>     response = self._open(req, data)
>   File "C:\Python24\lib\urllib2.py", line 376, in _open
>     '_open', req)
>   File "C:\Python24\lib\urllib2.py", line 337, in _call_chain
>     result = func(*args)
>   File "C:\Python24\lib\urllib2.py", line 1021, in http_open
>     return self.do_open(httplib.HTTPConnection, req)
>   File "C:\Python24\lib\urllib2.py", line 996, in do_open
>     raise URLError(err)
> urllib2.URLError: <urlopen error (10061, 'Connection refused')>
> 
> So reading through the EasyInstall instructions, I find that I need to
> stop it from downloading and point it at the local copy instead:
> 
> D:\downloads>ez_setup --allow-hosts=None --find-links="D:\downloads"
> setuptools
> Downloading
> http://cheeseshop.python.org/packages/2.4/s/setuptools/setuptools-0.6c3-py2.4.egg
> Traceback (most recent call last):
> [snip]
> urllib2.URLError: <urlopen error (10061, 'Connection refused')>
> 
> This I don't understand, as the docs explicitly state,
> "--allow-hosts=None prevents downloading altogether", which certainly
> isn't the case here. Even using the exact param layout for the example
> in the docs doesn't work:
> 
> D:\downloads>ez_setup -H None -f D:\downloads setuptools
> Downloading
> http://cheeseshop.python.org/packages/2.4/s/setuptools/setuptools-0.
> 6c3-py2.4.egg
> Traceback (most recent call last):
> [etc]
> 
> The difference is that I'm using ez_setup instead of easy_install, but
> then that's what I'm wanting to end up with out of this exercise. The
> docs do state that ez_setup uses the exact same comline args as
> easy_install...is this definitely the case?
> 
> Any help at all would be greatly appreciated. I feel like I'm missing
> something blatantly obvious...

ez_setup.py implies a certain setuptools version available. As you don't 
have that available, it will fallback to installing one, which explains 
the "still downloading"-thing.

The solution will most probably be to put the setuptools-egg on you 
python-path. I'm not sure if that is all to do, but to me it looks as if 
it might work after looking into ez_setup.py. If not, you should dig in 
there yourself.


Diez



More information about the Python-list mailing list