latest numpy & scipy - incompatible ?

robert no-spam at no-spam-no-spam.com
Sat Oct 28 16:54:53 CEST 2006


I'm using latest numpy & scipy. What is this problem ? :

>>> import scipy.stats
RuntimeError: module compiled against version 1000002 of C-API but this version of numpy is 1000009
Traceback (most recent call last):
  File "<interactive input>", line 1, in ?
  File "C:\PYTHON23\Lib\site-packages\scipy\stats\__init__.py", line 7, in ?
    from stats import *
  File "C:\PYTHON23\Lib\site-packages\scipy\stats\stats.py", line 191, in ?
    import scipy.special as special
  File "C:\PYTHON23\Lib\site-packages\scipy\special\__init__.py", line 8, in ?
    from basic import *
  File "C:\PYTHON23\Lib\site-packages\scipy\special\basic.py", line 8, in ?
    from _cephes import *
ImportError: numpy.core.multiarray failed to import
>>> import numpy.core.multiarray
>>> 
>>> import scipy
>>> scipy.__version__
'0.5.1'
>>> numpy.__version__
'1.0'
>>> 


-robert



More information about the Python-list mailing list