python interpreter on solaris 10

MrJean1 MrJean1 at gmail.com
Mon Sep 25 23:22:11 CEST 2006


FWIIW,

On my stock Ultra 20 / Solaris 10 / Opteron box, python, idle, etc.
just run fine provided /usr/sfw/bin is in your PATH environment
variable.  That is Python 2.3.3, however.

In addition, I installed the Python 2.4.3 build for Solaris from
ActiveState and python, idle, etc. run without any glitch as well.
More at <http://www.activestate.com/Products/ActivePython/?mp=1>

Lastly, I downloaded the very latest Python 2.5 release and tried to
build that using the SUN compilers.  There are some issues with that
since this is an Opteron and not a SPARC processor.

/Jean Brouwers


sam wrote:
> dear all,
>
> having spent the last couple of weeks getting to grips with python on
> windows, i am in the position of trying to make the transition to my
> newly arrived ultra 20.
>
> however, although there are plenty of files with idle somewhere in the
> title, idle.py (which i assume is the interpreter) will not open, as
> there is 'no installed viewer.' surely sun have not installed python
> only for it to unusable? i may well be completely off base here, as
> using unix is still very much a mystery to me.
>
> i have tried /usr/sfw/lib/python at the command prompt. it worked
> yesterday, but having now moved and restored the python2.3 file to its
> original position, i find the same command prompt failing to work. have
> i messed it up by moving it around?
>
> my workstation remains a shiny box which does naught but hum
> malevolently. is there hope?
> 
> thank you,
> 
> sam




More information about the Python-list mailing list