pythonol

John Martin news at dogstar.ukfsn.org
Wed Sep 27 19:52:35 CEST 2006


'pythonol' is a program for learning spanish. I think it's a really great
program. Unfortunately it ceased to work when I moved to SuSE 10 and 10.1 .
The author makes it clear on her website that she has devoted all the time
she's prepared to and won't maintain it. I think it's a shame as it's a
valuable educational tool. Sadly I know bugger all about python, this is
the error I get when running it.
---------------------------------------------------------------
/usr/share/Pythonol/sqlite/__init__.py:1: RuntimeWarning: Python C API version 
mismatch for module _sqlite: This Python has API version 1012, module
_sqlite has version 1011.
  import _sqlite
./pythonolui.py:137: DeprecationWarning: use gtk.UIManager
  itemf=ItemFactory(MenuBar, "<main>", ag)
./pythonolui.py:392: DeprecationWarning: use gtk.ComboBoxEntry
  conjcombo=Combo()
./pythonolui.py:398: Warning: unsupported arithmetic operation for flags
type
  conjtable.attach(conjcombo,1,2,1,2,(EXPAND+FILL),(0),0,0)
Traceback (most recent call last):
  File "./pythonolui.py", line 1945, in ?
    run()
  File "./pythonolui.py", line 1941, in run
    pythonolwin()
  File "./pythonolui.py", line 398, in __init__
    conjtable.attach(conjcombo,1,2,1,2,(EXPAND+FILL),(0),0,0)
TypeError: flag values must be strings, ints, longs, or tuples
------------------------------------------------------------------ 
Does anything stand out which might be fixable?

tia
-- 
John





More information about the Python-list mailing list