bsddb

skip at pobox.com skip at pobox.com
Tue Sep 26 21:23:55 CEST 2006


    Marc> "DB_VERSION_MISMATCH: Database environment version mismatch --
    Marc> Program version 4.4 doesn't match environment version 186187776.0"
    Marc> DBError: -30971

I haven't used bsddb much recently, but in the past I think this usually
meant that the Sleepycat folks released a new version of their package with
a new file format.  You're probably trying to read an old format file with a
newer version of their package.  There is a db_update command that's part of
Berkeley DB itself (not sure if the Windows installer for Python ships with
it) which should be able to read your old file and dump you a new one.

Skip



More information about the Python-list mailing list