Support SSL for Solaris 10

campos huwenyan at gmail.com
Thu Apr 5 18:11:08 CEST 2007


Hi all,

Last time I installed Python 2.5 by default, it didn't support SSL.
When I tried to use HTTPS, the following error occured:
AttributeError: 'module' object has no attribute 'ssl'

In README file:
----------------------------------------------------------------------------------------------
   (a) the band-aid fix is to link the _socket module statically
   rather than dynamically (which is the default).

   To do this, run "./configure --with-threads=no" including any
   other options you need (--prefix, etc.).  Then in Modules/Setup
   uncomment the lines:

   #SSL=/usr/local/ssl
   #_socket socketmodule.c \
   #       -DUSE_SSL -I$(SSL)/include -I$(SSL)/include/openssl \
   #       -L$(SSL)/lib -lssl -lcrypto

   and remove "local/" from the SSL variable.  Finally, just run
   "make"!
----------------------------------------------------------------------------------------------

I followed these steps. However I am puzzled with:
"remove "local/" from the SSL variable"

I tried several cases such as "/usr/ssl", "~/local/ssl", "/usr/local/
ssl"
All failed in building ssl module.

How to solve it?
Thanks in advance!




More information about the Python-list mailing list