tarfile module for version 2.2.3

billiejoex gnewsg at gmail.com
Fri Aug 24 10:26:05 CEST 2007


On 24 Ago, 09:57, Antoon Pardon <apar... at forel.vub.ac.be> wrote:
> I have to write a little program that has to run on a number of hosts.
> Versions of python range from 2.2.3. to 2.4.2.
>
> The easiest way to implement the necessary behaviour seems to me to
> use the tarfile module. However that was only introduced in 2.3
> I had a look in the code and at first sight couldn't find anything
> that would cause problems if I used this module with python 2.2.3.
>
> Could someone confirm that the tarmodule is compatible with python 2.2.
> I will try some tests myself but it would be nice to have confirmation
> from elsewhere.
>
> --
> Antoon Pardon

Try also the test suite (Lib/test/test_tarfile.py).




More information about the Python-list mailing list