Compiling Source with alternate Openssl lib

Kevin T. Ryan kevin.t.ryan at gmail.com
Wed Aug 29 04:46:17 CEST 2007


On Aug 28, 2:09 pm, "Kevin T. Ryan" <kevin.t.r... at gmail.com> wrote:
> Hi All -
>
> I'm trying to compile Python on a Centos machine (RHEL) 3.8 for a
> hosting account that I just set up and I'm having 2 issues:
>
> 1.  I ran into an issue with the "hashlib" module [I think] because it
> bumps it up against an *OLD* openssl lib (like, Feb. 2003).  So I
> installed a newer openssl lib, but when I recompiled python it still
> used the old library.  So I tried ./configure again with the flag: "-
> with-openssl-libs=/new/directory" but it still didn't work.  Any idea
> how I might be able to remedy this?  I have a working solution right
> now: I've commented out the last 2 lines of hashlib.py, but I'd rather
> not do that if I didn't have to.
>
> 2.  As part of this process, I installed "easy_install" and I was
> trying to download psycopg2 but I got the error: "PyDateTimeAPI
> defined but not used" when trying to compile.  I've had this problem
> before when trying to compile psycopg2 and it was because I didn't
> have the postgres header libs installed (libpq-dev) ... but that's on
> a debian box, and I can't figure out how to fix it on the RHEL one.
>
> I know the 2nd question might not belong in this group, but I thought
> I'd ask just in case someone ran into this before or might have any
> suggestions.
>
> Thanks in advance (as always!) for your help!
>
> Kevin

In case this helps anyone, I figured it out ... unfortunately, my dumb
a$$ didn't install Postgres before I tried to install the psycopg2
module!  I then still had issues, but after adding the postgres 'lib'
directory to the ld.so.config file (eg, cat "/dir/to/pgsql/lib" >> /
etc/ld.so.config and running ldconfig all is well!  Thanks,




More information about the Python-list mailing list