wxpython with python 2.5

Steve Holden steve at holdenweb.com
Thu Aug 2 18:36:18 CEST 2007


G wrote:
> Hello,
> 
> 
>      I am trying to get wxpython to run with python 2.5 without any 
> success. wx works prefectly in python 2.4. below is the error code i get 
> when i try to run the code.
> File "demo.py", line 3, in <module>
>     import Main
>   File "/tmp/wxPython/Main.py", line 32, in <module>
>     import wx                  # This module uses the new wx namespace
> ImportError: No module named wx
> 
> Any help in getting wxpython to run in 2.5 would be greatly appreciated.
> 
How did you install it, and was it a version specifically made to run 
with Python 2.5? You can't just install 2.5 and have it pick up all the 
libraries you installed for 2.4, you have to download and install 
updated versions.

At the moment it doesn't look as though 2.5 is seeing wxPython at all.

Sorry if this isn't the problem.

regards
  Steve
-- 
Steve Holden        +1 571 484 6266   +1 800 494 3119
Holden Web LLC/Ltd           http://www.holdenweb.com
Skype: holdenweb      http://del.icio.us/steve.holden
--------------- Asciimercial ------------------
Get on the web: Blog, lens and tag the Internet
Many services currently offer free registration
----------- Thank You for Reading -------------




More information about the Python-list mailing list