sqlobject 0.8.0b1 and python 2.5

Daniel Nogradi nogradi at gmail.com
Sat Jan 13 15:18:58 CET 2007


Hi list,

I get loads of DeprecationWarnings while using sqlobject 0.8.0b1 with
python 2.5. Does this mean that the sqlobject project is not very up
to date? Or should I just ignore them and happily use it? In general,
what's the status of sqlobject, will it be dropped altogether after
sqlobject2 is out?

Anyone's experience with this version of sqlobject would be very
helpful. Since I'm starting to use sqlobject right now, if there is a
similar ORM tool that is comparable but up to date and actively
developed, that would be an option too. (Things like SQLAlchemy are
waaaay to complicated and complex for my needs. :))

Thanks,
Daniel



More information about the Python-list mailing list