PyXML not installing?

Stefan Behnel stefan.behnel-n05pAM at web.de
Mon Jul 9 22:56:06 CEST 2007


Robert Dailey wrote:
> I downloaded the PyXML library and I'm attempting to install it by
> following the README file on Windows XP. I currently have Visual
> Studio 2005 installed.
> 
>>From the command line I type:
> 
> C:\PyXML-0.8.4>python setup.py build
> running build
> running build_py
> running build_ext
> error: Python was built with Visual Studio 2003;
> extensions must be built with a compiler than can generate compatible
> binaries.
> Visual Studio 2003 was not found on this system. If you have Cygwin
> installed,
> you can try compiling with MingW32, by passing "-c mingw32" to
> setup.py.
> 
> It gives me the above error message. Any way to fix this?

IIRC, Python extensions require MSVC 2003 on Windows and I don't think VC 2005
will work at all.

You may prefer using lxml for working with XML anyway. Version 1.2.1 has
binaries for Windows (and 1.3.2 will likely get them soon).

http://codespeak.net/lxml/

Stefan



More information about the Python-list mailing list