Tix not properly installed on OS X?

Jay Loden python at jayloden.com
Tue Jul 24 15:40:12 CEST 2007


Brian Blais wrote:
> Hello,
> 
> I am running OS X 10.4, on an Intel Mac, Python 2.5 not installed by  
> source (I used the binary install from the website). When I do the  
> following, I get an error:
> 
> Python 2.5.1 (r251:54869, Apr 18 2007, 22:08:04)
> [GCC 4.0.1 (Apple Computer, Inc. build 5367)] on darwin
> Type "help", "copyright", "credits" or "license" for more information.
>  >>> import Tix
>  >>> root=Tix.Tk()
> Traceback (most recent call last):
>    File "<stdin>", line 1, in <module>
>    File "/Library/Frameworks/Python.framework/Versions/2.5/lib/ 
> python2.5/lib-tk/Tix.py", line 210, in __init__
>      self.tk.eval('package require Tix')
> _tkinter.TclError: can't find package Tix
> 

I can confirm the same behavior and Google results are not promising: 

http://www.thescripts.com/forum/thread653175.html
http://aspn.activestate.com/ASPN/Mail/Message/ActivePython/3525325

I tried installing Tix from the binary TclAqua package, and when I run root=Tix.Tk() I still get the same error (though, interestingly, a Tk window does open). Looks like your best bet right now would be to install Tix via fink if that's an option.

-Jay



More information about the Python-list mailing list