trouble with sqlite under debian etch

Gerhard Häring gh at
Tue Jul 3 16:36:35 CEST 2007

Rustom Mody wrote:
> I was trying to follow the sqlalchemy tutorial on my debian etch box
> and got stuck with installation.  Any help/pointers will be welcome.
> First after installing sqlalchemy needed some sqlite package
> synaptic showed me packages python-pysqlite, python-pysqlite1.1 and
> python-pysqlite2.
> [...]

Or just use Python 2.5, which includes a "sqlite3" module that 
SQLAlchemy can use.

> Theres some confusion regarding numbers: python-pysqlite2 is for
> sqlite3 or some such thing

the 2 in python-pysqlite2 is for

> Tried python-pysqlite1.1 and got errors. Tried 2 and got version warnings.
> Downloaded the tgz and did a setup build followed by a setup install
> Now the
>>>> db = create_engine('sqlite:///tutorial.db')
> gives me no module _sqlite

Did you execute that in the pysqlite root directory (i. e. the one that 
"" and friends are?). Unfortunately, any other working directory 
will be ok, but this one isn't.

-- Gerhard

More information about the Python-list mailing list