Compatibility of python2.5 with pytohn2.3

Gerhard Häring gh at ghaering.de
Wed Jul 18 13:36:24 CEST 2007


VISHAL KANAUJIA wrote:
> Hi all,
>  I am new member of this post. I have a C application which uses
> Python(version 2.3) extensively with SWIG wrappers. I want to upgrade
> the Python to latest version2.5.
> 
> Is there any compatibility issue between two versions? Does latest
> Python2.5 provide backward compatibility to previous Python (Version
> 2.3 in my case) constructs.

Short answer: yes.

I've never had any issues here (compiling Python extension code in newer
Python versions). The other way around that's of course not the case. I
have to test my extension code against Python 2.4 and Python 2.3 regularly,
because otherwise issues arise where I wouldn't have expected them, like
even simple macros like PyDict_CheckExact not being present in older Python
versions.

-- Gerhard




More information about the Python-list mailing list