Windows build of PostgreSQL library for 2.5

George Sakkis george.sakkis at gmail.com
Wed Jun 13 19:34:15 CEST 2007


On Jun 13, 12:57 pm, Ben Sizer <kylo... at gmail.com> wrote:
> On 30 May, 16:20, Ben Sizer <kylo... at gmail.com> wrote:
>
> > On 30 May, 15:42, Frank Millman <f... at chagford.com> wrote:
>
> > > On May 30, 4:15 pm,BenSizer<kylo... at gmail.com> wrote:
>
> > > > I've been looking for a Windows version of a library to interface to
> > > > PostgreSQL, but can only find ones compiled under Python version 2.4.
> > > > Is there a 2.5 build out there?
>
> > > Is this what you are looking for?
>
> > >http://stickpeople.com/projects/python/win-psycopg/
>
> > It may well be, thanks.
>
> On second thoughts, is there one anywhere without an extra multi-
> megabyte dependency? This seems to rely on the eGenix 'mx' library.
>
> --
> Ben Sizer

IIRC version 2 (psycopg2) doesn't depend on mx:
http://www.stickpeople.com/projects/python/win-psycopg/psycopg2-2.0.5.1.win32-py2.5-pg8.2.0-release.exe

George




More information about the Python-list mailing list