*Naming Conventions*

Steve Howell showell30 at yahoo.com
Sun Jun 3 22:32:32 CEST 2007


--- Thorsten Kampe <thorsten at thorstenkampe.de> wrote:
> 
> for validanswer in validanswers:
>     if myAnswers.myanswer in
> myAnswers.validAnswers[validanswer]:
>         MyOptions['style'] = validanswer
> 

I can at least sympathize with your problem, although
I don't have a great solution for you.  I often have
trios of variables like this:

   answer_dct
   answers
   answer

English mostly pluralizes with an "s," but I sometimes
resort to bad English to keep the convention going:

   mouse_dct
   mouses (not mice)
   mouse

I also still waste brain cycles on naming
dictionaries.  Sometimes I name the dictionary after
the values it stores, sometimes after the keys it
uses, and sometimes after both.




      ____________________________________________________________________________________
Luggage? GPS? Comic books? 
Check out fitting gifts for grads at Yahoo! Search
http://search.yahoo.com/search?fr=oni_on_mail&p=graduation+gifts&cs=bz



More information about the Python-list mailing list