int vs long

Marc 'BlackJack' Rintsch bj_666 at gmx.net
Mon Jun 4 11:36:05 CEST 2007


In <f40jll$1kp$00$1 at news.t-online.com>, Peter Otten wrote:

>> Hm, my test above was from 2.5!?
> 
> Then your installation is broken. What does
> 
>>>> import itertools
>>>> itertools
> <module 'itertools' from
> '/usr/local/lib/python2.5/lib-dynload/itertools.so'>
> 
> print? 

Python 2.5 (r25:51908, Oct  6 2006, 15:22:41)
[GCC 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import itertools
>>> itertools
<module 'itertools' from '/usr/lib/python2.5/lib-dynload/itertools.so'>

> By the way, here's what I get if I force the wrong library upon python2.5:
> 
> /usr/local/lib/python2.4/lib-dynload $ python2.5
> Python 2.5 (r25:51908, Oct  3 2006, 08:48:09)
> [GCC 3.3.3 (SuSE Linux)] on linux2

Seems to be the same Python version, just build three days earlier and
with a different GCC version.  Weird.

Ciao,
	Marc 'BlackJack' Rintsch



More information about the Python-list mailing list