mxtextools, py2app, and intel vs. PPC

Ian A. York iayork at panix.com
Tue Jun 5 13:18:30 CEST 2007


I've been packaging a set of scripts using py2app, and until now the app
that results has run without issues on MacOS10.4, either intel or ppc.  

The latest version made by py2app, however, only runs on intel (on which I 
made the py2app package).  The problem seems to be with eGenix mx base 
package (which is needed for BioPython).  The package when run on PPC gets 
the error "No module named TextTools", although TextTools is included and 
works fine on intel. If I include TextTools specifically in the Resources 
folder within the package, instead I get an error "ImportError: 
Inappropriate file type for dynamic loading".  Again, these errors only 
appeared on the ppc platform, not on intel.

I worked around the problem by including (in the Resources folder) the 
TextTools from a PPC machine, and the package then runs on both machines. 
This isn't a great solution, because I don't always have easy access to a 
PPC machine running MacOS10.4.  

I presume that the problem is that the mx package I have on the Intel 
machine isn't actually a Universal binary, and so the PPC has no access to 
that module.  I've tried installing the mx package from source, and from 
the prebuilt binary, without fixing the problem.

Anyone know if my guess is right, that the mx package isn't coming in as a 
universal?  And if so, if there's a way to force it to be universal, or 
some other simple fix for my problem?

Thanks,

Ian
-- 
    Ian York   (iayork at panix.com)  <http://www.panix.com/~iayork/>
    "-but as he was a York, I am rather inclined to suppose him a
     very respectable Man." -Jane Austen, The History of England



More information about the Python-list mailing list