installing "pysqlite"

Paul Boddie paul at boddie.org.uk
Thu Mar 1 14:40:43 CET 2007


On 1 Mar, 12:46, "Nader" <n.em... at gmail.com> wrote:
>
> ldd returens the next result:
> ldd /usr/people/emami/lib/python2.4/site-packages/pysqlite2/_sqlite.so
>     linux-gate.so.1 =>  (0xffffe000)
>     libpthread.so.0 => /lib/tls/libpthread.so.0 (0x40040000)
>     libc.so.6 => /lib/tls/libc.so.6 (0x40050000)

I think you pasted the nm result in here, but you seem to be missing
libsqlite3.so.0 (from what I see myself). From what I've just read
about linux-gate.so, the linker can't seem to find the SQLite
libraries. More on linux-gate.so here:

http://www.trilithium.com/johan/2005/08/linux-gate/

> and the 'nm' gives this:
>
> nm usr/people/emami/lib/libsqlite3.so | grep  sqlite3_set_authorize
> 0000ce40 T sqlite3_set_authorizer

That looks alright.

>         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

I guess this was the end of the ldd result.

I'm out of ideas, unfortunately. I think you should experiment with
LD_LIBRARY_PATH and run ldd again to see if you can get it to show
libsqlite3.so.0. The pysqlite mailing list might be the best place to
ask for help if that doesn't work. Sorry!

Paul




More information about the Python-list mailing list