wxPython import error...

Chris Mellon arkanes at gmail.com
Tue Mar 6 17:06:00 CET 2007


On 4 Mar 2007 16:42:07 -0800, king kikapu <aboudouvas at panafonet.gr> wrote:
> Hi,
>
> i am just completed installing Python/Pydev/Eclipse/wxPython on an
> Ubuntu system and all are running fine except program that contains
> references to wx
>
> It gives me:
> ImportError: /usr/lib/python2.4/site-packages/wx-2.8-gtk2-unicode/wx/
> _core_.so: undefined symbol: PyUnicodeUCS4_FromEncodedObject
>
> I installed the wx packages the way the wx web site says, especially
> for Ubuntu.
>
> Can anyone help with this as i have been searching the net for this
> with no luck...
>
> Thanks for any help
>
> --


This looks like you somehow installed the Redhat packages instead -
Redhat builds their Python with UCS4, everyone else uses UCS2. Did you
download the RPMs and convet them rather than adding the wxCommunity
repo to your sources.lst?



More information about the Python-list mailing list