upgrading python (and other modules)

kyosohma at gmail.com kyosohma at gmail.com
Thu Mar 29 16:02:34 CEST 2007


On Mar 29, 1:14 am, Astan Chee <s... at al.com.au> wrote:
> Forget I asked this question.
> I've solved it using wxPython 2.6.3.3
> Cheers
>
> Astan Chee wrote:
> > Hi,
> > I was once using python 2.4 in win2k with wxPython 2.4.2.4 (if im not
> > mistaken) with it.
> > Now i've upgraded to winXP and am using python 2.5 with wxPython 2.8.1.1.
> > The problem Im currently having is that in my code:
>
> > from wxPython.wx import *
> > from wxPython.grid import *
> > from wxPython.html import *
>
> > no longer works. An error/warning appears:
>
> > Warning (from warnings module):
> >   File "C:\stanc_home\WHIP\whip.py", line 7
> >     from wxPython.wx import *
> > DeprecationWarning: The wxPython compatibility package is no longer
> > automatically generated or activly maintained.  Please switch to the wx
> > package as soon as possible.
>
> > Traceback (most recent call last):
> >   File "C:\stanc_home\WHIP\whip.py", line 10, in <module>
> >     from wxPython.html import *
> >   File "C:\Python25\lib\site-packages\wx-2.8-msw-ansi\wxPython\html.py",
> > line 151, in <module>
> >     wxHtmlWindowEvent = wx.html.HtmlWindowEvent
> > AttributeError: 'module' object has no attribute 'HtmlWindowEvent'
>
> > How should I be importing in the new wx?
> > Thanks!
> > Astan

The wxPython community typically recommends NOT doing a "from
wxPython.wx import *" due to the increased likelihood of namespace
poisoning. If you really want to know how to do it anyway, you should
contact the wxPython users group directly at http://wxpython.org/maillist.php

Mike




More information about the Python-list mailing list