How to link different site-packages to different Python?

Boris Borcic bborcic at gmail.com
Fri Nov 9 13:01:35 CET 2007


Davy wrote:
> Hi all,
> 
> I have Python 2.4 and 2.5 in my PC. And PythonWin is installed as IDE.
> 
> When I tried to use site-packages "Numpy", I installed the both
> version (i.e. for 2.4 and 2.5).
> 
> Python 2.4 and Numpy for it work together well.
> 
> But when I type "from numpy import *" in Python 2.5. It throw out an
> error indicate that the numpy library is link to Python 2.4 package?
> How to fix this problem?

Shouldn't occur if you properly installed python+pythonwin+numpy
from their respective installer once for each of python 2.4 and 2.5. You may use
the (Tools/Browse Pythonpath) and (Tools/Edit PythonPath) menu items in each of
Pythonwin 2.4 and 2.5 to sort things out. If your lazyness isn't caused by your
impatience, a possibility is to deinstall and then reinstall everything :)



More information about the Python-list mailing list