python - an eggs...

Diez B. Roggisch deets at nospam.web.de
Sun Nov 11 19:03:03 CET 2007


bruce schrieb:
> Hi Diez...
> 
> In my case, I do a "python setup.py install" and i get a Durus...egg
> installed in the /usr/lib/python2.4/site-packages/ dir... As I understand
> it, this egg/file contains compressed pythonic files.
> 
> When I run the app which uses the durus stuff... the app crashes, and
> displays the durus python script with a path. However, when I simply
> cut/copy the path, and attempt to view that file, the path doesn't exist on
> the drive. I'm assuming that there is some sort of relative offset action
> going on, but that the file actually doesn't exist, except within the egg
> itself.


You can unzipp eggs as well, creating a directory that ends in .egg - 
that works the same.

> I've also tried to simply modify the original source file, without
> rebuilding the egg, which obviously doesn't affect the egg file.

Then after modification, reinstall.
> 
> So, for now, the only way I can see to modify the src, is to go back to the
> src files, modify, and rebuild the durus app.
> 
> I don't see any "setuptools" neither setuptools, nor "man setuptools"
> returns anything on my system.

setuptools is a package that installs & creates eggs. You find it 
documented here:

http://peak.telecommunity.com/DevCenter/setuptools

It comes with a few commandline-scripts after installation, such as

easy_install



> when i run "python setup.py develop" and I then run my app, it crashes,
> complaining of a persisten object not being found.... So I don't think
> that's the immediate solution.


I can't comment on that, but usually that shouldn't be the case just 
because of the development mode.

Diez



More information about the Python-list mailing list