Parallel Python environments..

Gabriel Genellina gagsl-py2 at yahoo.com.ar
Tue Nov 6 23:07:28 CET 2007


En Tue, 06 Nov 2007 18:43:10 -0300, bruce <bedouglas at earthlink.net>  
escribió:

> if i have python 2.4.3 installed, it gets placed in the python2.4 dir..  
> if i
> don't do anything different, and install python 2.4.2, it too will get
> placed in the python2.4 tree... which is not what i want.

Any reason you want to keep 2.4.2 *and* 2.4.3 separate? The latter is only  
a bugfix over the 2.4 version - anything working on 2.4.2 should work on  
2.4.3. And 2.4.4, the latest bugfix on that series. Binaries, shared  
libraries, extensions, etc. targetted to 2.4x should work with 2.4.4
You may want to have separate directories for 2.4 and 2.5, yes; binaries,  
shared libraries and extensions do NOT work across versions changing the  
SECOND digit. But changes on the THIRD digit should not have compatibility  
problems.

-- 
Gabriel Genellina




More information about the Python-list mailing list