Python on Leopard issues

Nicholas Bastin nick.bastin at gmail.com
Thu Nov 8 22:59:33 CET 2007


On Nov 8, 2007 4:13 PM, Chris <listservs at mac.com> wrote:
> Are others having fundamental issues on OSX 10.5 with python 2.5.1? I was
> excited that Python 2.5 was included, but this excitement was very short
> lived. Almost nothing works. Upon startup I get this message:
>
> 'import site' failed; use -v for traceback
>
> and sure enough, all of the built-in packages are non-existent. I'm not sure
> why Apple bothered including an improperly-configured version. Does
>  anyone have an easy fix for this, or should I go to ActiveState and install a
> version that works?

A fresh full install of leopard does not have this problem, nor does
my machine with a simple upgrade.  Typically when import site fails,
your environment is screwed up.  Does 'which python' give you:
/Library/Frameworks/Python.framework/Versions/Current/bin/python?

Also, Apple distributes the standard library in a zip file, so you
won't find all the packages just lying around.  They should all be
stored in /Library/Frameworks/Python.framework/Versions/2.5/lib/python25.zip.

--
Nick



More information about the Python-list mailing list