How to link different site-packages to different Python?

Davy zhushenli at gmail.com
Fri Nov 9 11:19:13 CET 2007


Hi all,

I have Python 2.4 and 2.5 in my PC. And PythonWin is installed as IDE.

When I tried to use site-packages "Numpy", I installed the both
version (i.e. for 2.4 and 2.5).

Python 2.4 and Numpy for it work together well.

But when I type "from numpy import *" in Python 2.5. It throw out an
error indicate that the numpy library is link to Python 2.4 package?
How to fix this problem?


The error pasted below is copied from Python 2.5 PythonWin console:
Traceback (most recent call last):
  File "<interactive input>", line 1, in <module>
  File "C:\Program Files\nupic-1.4\lib\python2.4\site-packages\numpy
\__init__.py", line 39, in <module>
    import core
  File "C:\Program Files\nupic-1.4\lib\python2.4\site-packages\numpy
\core\__init__.py", line 5, in <module>
    import multiarray
ImportError: Module use of python24.dll conflicts with this version of
Python.

Best regards,
Davy




More information about the Python-list mailing list