bsddb in python 2.5.1

BjornT bjorn.tipling at gmail.com
Sun Nov 4 00:12:35 CET 2007


Have a rather big problem with bsddb I can't figure out. I upgraded an
Ubuntu machine from 7.05 to 7.10 which upgraded python to 2.5.1

I run a local website that uses bsddb, and suddenly I get a version
mismatch error with bsddb and I can't access my database anymore

I noticed in the 2.5.1 release notes:

- fixed a bug with bsddb.DB.stat: the flags and txn keyword arguments
  were transposed.

- Added support for linking the bsddb module against BerkeleyDB 4.5.x.

http://www.python.org/download/releases/2.5.1/NEWS.txt

I know that when you upgrade Berkeley DB you're supposed to go through
steps solving this problem,but I wasn't expecting an upgrade. I've
tried to use different versions bsddb3, 4.4 and 4.5, (instead of bsddb
that comes with python 2.5.1) with different versions of Berkeley DB
installs (4.5 and 4.4 - built from source into /usr/local). But this
isn't working.

I can't seem a way to figure out how to recover my data. Please help. :
(




More information about the Python-list mailing list