bsddb in python 2.5.1

"Martin v. Löwis" martin at v.loewis.de
Sun Nov 4 09:04:38 CET 2007


> I know that when you upgrade Berkeley DB you're supposed to go through
> steps solving this problem,but I wasn't expecting an upgrade. I've
> tried to use different versions bsddb3, 4.4 and 4.5, (instead of bsddb
> that comes with python 2.5.1) with different versions of Berkeley DB
> installs (4.5 and 4.4 - built from source into /usr/local).

There seems to be an important misconception here. Python 2.5.1 does
not come with any bsddb version whatsoever. If you have a Python binary
where the bsddb module is linked with a certain version of Python, that
was the choice of whoever made the Python binary.

For acccess to the database, the Python version does not matter at all.
What matters is the version of Berkeley DB.

So as the first step, you should find out what version of Berkeley DB
the old Python installation was using, and what version of Berkeley DB
the new version is using.

I'm also not sure what you mean by "I've tried to use different version
bsddb3, 4.4 and 4.5". What specifically did you do to try them? AFAICT,
Ubuntu "Feisty Fawn" linked its Python with bsddb 4.4, so you should
have no version issues if you really managed to use bsddb 4.4.

Can you please report the specific error you got? According to the
Berkeley DB documentation, there was no change to database formats
in Berkeley DB 4.5 (but there was a change to the log file format).

Regards,
Martin



More information about the Python-list mailing list