Build Python 2.5 against Tk 8.5

"Martin v. Löwis" martin at v.loewis.de
Tue Oct 16 20:41:25 CEST 2007


> It's been a while, but when I've tried to run my Tkinter app against Tk
> 8.5 with a stock Python installation, I get an error message saying that
> Tk 8.4.x is required. 

Can you please clarify what you mean by "stock Python installation"?
I just built Python 2.5.1 with Tk 8.5 on Debian unstable, and it works
fine.

> It's probably tkinter.so that hard-codes the
> Tcl/Tk version, not Python itself--I should have been clearer on that.

It's still not clear. I'm the current maintainer of the _tkinter module,
and I can assert that _tkinter.c does *not* hard-code Tk 8.4. As you
refer to _tkinter.so, it appears you are talking about a precompiled
version - did you try to build Python yourself?

Regards,
Martin



More information about the Python-list mailing list