setuptools on mac

Calvin Spealman ironfroggy at gmail.com
Sat Oct 6 19:35:19 CEST 2007


I am trying to install the newest setuptools on my macbook. 2.3 was
installed by default, and 2.4 is installed and is my default version
now. However, when I try to import setuptools, which is required to
_install_ setuptools, I get this error:

macbkpro1:~/Desktop/setuptools-0.6c7 ironfroggy$ python setup.py install
Traceback (most recent call last):
  File "setup.py", line 7, in ?
    execfile(convert_path('setuptools/command/__init__.py'), d)
  File "setuptools/command/__init__.py", line 13, in ?
    from distutils.command.bdist import bdist
  File "/Library/Frameworks/Python.framework/Versions/2.4//lib/python2.4/distutils/command/bdist.py",
line 29, in ?
    class bdist (Command):
  File "/Library/Frameworks/Python.framework/Versions/2.4//lib/python2.4/distutils/command/bdist.py",
line 33, in bdist
    user_options = [('bdist-base=', 'b',
  File "/Library/Frameworks/Python.framework/Versions/2.4//lib/python2.4/distutils/util.py",
line 78, in get_platform
    cfgvars = get_config_vars()
  File "/Library/Frameworks/Python.framework/Versions/2.4//lib/python2.4/distutils/sysconfig.py",
line 488, in get_config_vars
    func()
  File "/Library/Frameworks/Python.framework/Versions/2.4//lib/python2.4/distutils/sysconfig.py",
line 373, in _init_posix
    raise DistutilsPlatformError(my_msg)
distutils.errors.DistutilsPlatformError: $MACOSX_DEPLOYMENT_TARGET
mismatch: now "10.4" but "10.3" during configure
macbkpro1:~/Desktop/setuptools-0.6c7 ironfroggy$

-- 
Read my blog! I depend on your acceptance of my opinion! I am interesting!
http://ironfroggy-code.blogspot.com/



More information about the Python-list mailing list