Build Python 2.5 against Tk 8.5

Russell E. Owen rowen at cesmail.net
Tue Oct 16 20:20:32 CEST 2007


In article <4714D4AB.3080103 at codebykevin.com>,
 Kevin Walzer <kw at codebykevin.com> wrote:

> Martin v. Löwis wrote:
> >> I'd like to experiment with Tk 8.5 (now in beta) in my Python
> >> application, but Python 2.5 requires Tk 8.4.x.
> > 
> > Why do you say that? AFAIK, that's not the case.
> 
> It's been a while, but when I've tried to run my Tkinter app against Tk 
> 8.5 with a stock Python installation, I get an error message saying that 
> Tk 8.4.x is required. It's probably tkinter.so that hard-codes the 
> Tcl/Tk version, not Python itself--I should have been clearer on that. 
> However, I still need to know what to patch...

I have no idea how Tkinter does with Tcl/Tk 8.5.

But one way to try it is to build python from source (after installing 
Tcl/Tk 8.5). It's not hard, but it takes awhile and you have to specify 
the right options to get a framework build (these are documented in the 
build instructions).

-- Russell



More information about the Python-list mailing list